Home
AudioAsylum Trader
Planar Speaker Asylum

Welcome! Need support, you got it. Or share your ideas and experiences.

For Sale Ads

FAQ / News / Events

 

Use this form to submit comments directly to the Asylum moderators for this forum. We're particularly interested in truly outstanding posts that might be added to our FAQs.

You may also use this form to provide feedback or to call attention to messages that may be in violation of our content rules.

You must login to use this feature.

Inmate Login


Login to access features only available to registered Asylum Inmates.
    By default, logging in will set a session cookie that disappears when you close your browser. Clicking on the 'Remember my Moniker & Password' below will cause a permanent 'Login Cookie' to be set.

Moniker/Username:

The Name that you picked or by default, your email.
Forgot Moniker?

 
 

Examples "Rapper", "Bob W", "joe@aol.com".

Password:    

Forgot Password?

 Remember my Moniker & Password ( What's this?)

If you don't have an Asylum Account, you can create one by clicking Here.

Our privacy policy can be reviewed by clicking Here.

Inmate Comments

From:  
Your Email:  
Subject:  

Message Comments

   

Original Message

RE: No, Tim - as Norman posted ...

Posted by andyr on September 10, 2020 at 15:12:48:

I have removed both fuses & fuse-holders.

The ribbon blew because the amp was pumping out positive-only square waves; unfortunately, my testing was not sufficient (before connecting it up to my Maggies).

Andy