Home Speaker Asylum

General speaker questions for audio and home theater.

Plugged my Spica TC-50s in for the first time in years

While cleaning up the third floor of my house, which has a huge room that accumulated all the stuff we never had another place for, my wife wanted music. And one of the things that managed to find itself there were my TC-50s. They were actually meant to be used for my bike trainer, but never were.

I used my iPhone7 with Tidal Hifi, my Dragonfly Black DAC, and an unknown class-D amp board held together with tape. I turned it on, hit play on the iPhone, and Chryssie Hynde and the Pretenders just started singing. I was dumbfounded on how good it sounded. They had much more bass than I remember, one of the reasons I eventually replaced them.

The drivers seem to be in good shape. I remember looking for replacements years ago, or maybe just reading about someone else looking, and they aren't available. (I seem to have a knack for owning irreplaceable equipment, Grace F9E stylus for another). As I recall too, these things are very inefficient, something like 81db. Even my big Proac clones need less power than these. Tube amps just can't drive them, another reason I stopped using them. I remember placing the TC-50s on top of the Proac clones and plugging them into my main system, leaving the volume where it was and it was barely audible. I had to turn it way up to get even soft listening levels.


This post is made possible by the generous support of people like you and our sponsors:
  Kimber Kable  


Topic - Plugged my Spica TC-50s in for the first time in years - zacster 05:36:07 02/19/17 (8)

FAQ

Post a Message!

Forgot Password?
Moniker (Username):
Password (Optional):
  Remember my Moniker & Password  (What's this?)    Eat Me
E-Mail (Optional):
Subject:
Message:   (Posts are subject to Content Rules)
Optional Link URL:
Optional Link Title:
Optional Image URL:
Upload Image:
E-mail Replies:  Automagically notify you when someone responds.