Home Propeller Head Plaza

Technical and scientific discussion of amps, cables and other topics.

I say a bad solder joint

I have an integrated SS amp that does that once in a while. Sometimes, I just tightened the speaker connections to fix it, but increasing the volume would fix it as well. So, you are definitely dealing with a bad connection somewhere.

I have a tube amplifier that for the longest time was blowing a particular output tube quite regularly. What a pain. Eventually, I examined the socket and saw the BAD tube socket pin that wasn't well soldered. Don't know why I couldn't figure that out sooner.

Open the unit (after it's been cold for a while). Get a good light and, maybe, a loupe would help to see better. Examine every solder joint and make a note if one seems subpar, maybe use a marker. If after this exercise, you only have one or two marked at most, then go ahead and reflow the solder on these joints. Usually, there was insufficient solder applied, so you will have to add some. If you can't solder, but can see, find the bad connections yourself and take it to someone who can solder. Usually a 25-watt iron will do the trick and buy some solder for electronics assembly.

Most likely, the problem solder joint is in the signal path on the channel with the problem.


This post is made possible by the generous support of people like you and our sponsors:
  K&K Audio / Lundahl Transformers   [ K&K Audio / Lundahl Transformers Forum ]


Follow Ups Full Thread
Follow Ups
  • I say a bad solder joint - jedrider 16:06:50 03/06/15 (0)

FAQ

Post a Message!

Forgot Password?
Moniker (Username):
Password (Optional):
  Remember my Moniker & Password  (What's this?)    Eat Me
E-Mail (Optional):
Subject:
Message:   (Posts are subject to Content Rules)
Optional Link URL:
Optional Link Title:
Optional Image URL:
Upload Image:
E-mail Replies:  Automagically notify you when someone responds.