Asylum Feedback/Support

Audio Asylum feedback, support and feature wish list.

Return to Asylum Feedback/Support


Message Sort: Post Order or Asylum Reverse Threaded

Trader error

96.37.198.203

Posted on June 5, 2019 at 18:34:30
1973shovel
Audiophile

Posts: 9158
Location: Greenville SC
Joined: February 25, 2007



Hi Rod,

My first time attempt to post an ad in the Trader, about 9:30 PM Eastern on 6/05/19, and got the above error message. I was signed in, by the way.

Thanks.


 

Hide full thread outline!
    ...
RE: Trader error, posted on June 5, 2019 at 20:45:57
Rod M
Web Geek

Posts: 12808
Location: So. California
Joined: March 1, 1999
Contributor
  Since:
March 1, 1999
Wow, I looked at the code and I can only guess that something went awry with the db server, yet, all is fine now at 9:00PM PT.

Try it again and let me know. I'm traveling home from vacation tomorrow, so I'll check in that evening.

-Rod

 

Nope, posted on June 6, 2019 at 06:46:03
1973shovel
Audiophile

Posts: 9158
Location: Greenville SC
Joined: February 25, 2007
Tried it again just now at 9:50 AM EST 6/6/19. This time I clicked on the "raw error" link as shown in my first post's screen shot. Results are copied and pasted below.

I hope your vacation was good!

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Can't call method "is_active_member" on an undefined value at /pub/www/AudioAsylumTrader/ca/comps/post_body line 122.


Trace begun at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/Exceptions.pm line 129
HTML::Mason::Exceptions::rethrow_exception('Can\'t call method "is_active_member" on an undefined value at /pub/www/AudioAsylumTrader/ca/comps/post_body line 122.^J') called at /pub/www/AudioAsylumTrader/ca/comps/post_body line 122
HTML::Mason::Commands::('cat', 'psv_comp') called at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run('HTML::Mason::Component::FileBased=HASH(0x7fcdb5b32c70)', 'cat', 'psv_comp') called at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/Request.pm line 1302
eval {...} at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/Request.pm line 1292
HTML::Mason::Request::comp(undef, undef, 'cat', 'psv_comp') called at /pub/www/AudioAsylumTrader/ca/post.html line 36
HTML::Mason::Commands::('cat', 'psv_comp') called at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/Component.pm line 135
HTML::Mason::Component::run('HTML::Mason::Component::FileBased=HASH(0x7fcdb3832bd8)', 'cat', 'psv_comp') called at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/Request.pm line 1297
eval {...} at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/Request.pm line 1292
HTML::Mason::Request::comp(undef, undef, undef, 'cat', 'psv_comp') called at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/Request.pm line 481
eval {...} at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/Request.pm line 481
eval {...} at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/Request.pm line 433
HTML::Mason::Request::exec('HTML::Mason::Request::ApacheHandler=HASH(0x7fcdb598ea10)') called at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/ApacheHandler.pm line 168
HTML::Mason::Request::ApacheHandler::exec('HTML::Mason::Request::ApacheHandler=HASH(0x7fcdb598ea10)') called at /opt/local/lib/perl5/vendor_perl/5.16.3/HTML/Mason/ApacheHandler.pm line 825
HTML::Mason::ApacheHandler::handle_request('HTML::Mason::ApacheHandler=HASH(0x7fcdb33c7b60)', 'Apache2::RequestRec=SCALAR(0x7fcdb38330d0)') called at (eval 51) line 8
HTML::Mason::ApacheHandler::handler('HTML::Mason::ApacheHandler', 'Apache2::RequestRec=SCALAR(0x7fcdb38330d0)') called at -e line 0
eval {...} at -e line 0

 

RE: Nope, posted on June 6, 2019 at 07:41:09
Rod M
Web Geek

Posts: 12808
Location: So. California
Joined: March 1, 1999
Contributor
  Since:
March 1, 1999
I just tried posting a new ad and it worked just fine. Looking at the code, I can't see anything different or changed. I did find a couple of old ads and possibly previewed and not completed ones. I deleted them just to try something.

We're leaving for the road now. If it's still a problem, I'll need to know exactly where it happens in the process and preferably a screen shot of the page before you click to post or preview.
-Rod

 

OK, I believe I sorted it out, posted on June 6, 2019 at 08:36:11
1973shovel
Audiophile

Posts: 9158
Location: Greenville SC
Joined: February 25, 2007
It doesn't make any sense to me, but it may to you...

I was signed into my Asylum account, so I could answer posts, etc. but got the Trader error after clicking on "Post an ad" and then clicking on any category I wanted to run an ad in.

I just went to the Trader main page again, and noticed there's a Register / Log In on the upper right of that page too. I logged in a second time (having already been signed into my main Asylum account), and now it looks like it will allow me to post ads, although I haven't actually tried it yet.

Oh, and as another FYI, the Trader sign in page is indicating the sign in isn't secure, as shown in the screen shot below.





Drive safe, and thanks for all you do.

 

RE: OK, I believe I sorted it out, posted on June 6, 2019 at 17:47:01
Rod M
Web Geek

Posts: 12808
Location: So. California
Joined: March 1, 1999
Contributor
  Since:
March 1, 1999
Yeah, that was the next thing that I was going to ask you. The Trader is a different domain, so we can't get a login cookie from the Asylum. But, since the db is common, your login works on both sites.

The code is supposed to redirect to a login page if you aren't logged in to the Trader. There's something about your steps that misses the error catch, so I can get it fixed tomorrow.

Thanks for the help.

-Rod

 

Thank you, posted on June 7, 2019 at 06:08:13
1973shovel
Audiophile

Posts: 9158
Location: Greenville SC
Joined: February 25, 2007
I can now see how my, "I was signed in, by the way." in my original post must have confused you, with me not realizing I had to sign into the Trader separately. And no, as you've already surmised, there was no redirect.

Much appreciated, Rod.

 

Page processed in 0.020 seconds.