Planar Speaker Asylum

Welcome! Need support, you got it. Or share your ideas and experiences.

Return to Planar Speaker Asylum


Message Sort: Post Order or Asylum Reverse Threaded

Start up thump/pop in the amp and quad 63

172.58.139.118

Posted on July 10, 2020 at 08:41:55
Wojciech
Audiophile

Posts: 2107
Joined: June 23, 2009
Is the usual (for some amps) startup thump/pop dangerous for quad ESL63 speakers ?
TIA , W

 

Hide full thread outline!
    ...
RE: Start up thump/pop in the amp and quad 63, posted on July 12, 2020 at 05:07:30
Story
Audiophile

Posts: 3646
Location: NJ
Joined: December 11, 2000
Contributor
  Since:
February 21, 2019
Does the 63 have fuse protection? If so just make sure they are the correct value and type i.e. fast blow or whatever.

Some start up thumps at turn on depend on the design of the amp. Which amp are you using?


"Bass is the place..the rest is filigree and lace" Doug Sax


 

RE: Start up thump/pop in the amp and quad 63, posted on September 16, 2020 at 10:00:57
john65b
Audiophile

Posts: 325
Location: Chicago
Joined: July 19, 2005
Likely your preamp...Start preamp first, count to 30, then turn on amp. Upon shut down the opposite.

Also could be amp - but my bet is pre, especially if tubed...


I VOID WARRANTIES

 

RE: Start up thump/pop in the amp and quad 63, posted on September 16, 2020 at 15:38:39
Wojciech
Audiophile

Posts: 2107
Joined: June 23, 2009
No, its the amp. Minimalist British
design(DNM) without any delay circuit. The designer said it won't be any problem since early Quad SS amps were also thumping on power up.

 

Page processed in 0.024 seconds.