Home
AudioAsylum Trader
Tubes Asylum

Questions about tubes and gear that glows. FAQ

For Sale Ads

FAQ / News / Events

 

Use this form to submit comments directly to the Asylum moderators for this forum. We're particularly interested in truly outstanding posts that might be added to our FAQs.

You may also use this form to provide feedback or to call attention to messages that may be in violation of our content rules.

You must login to use this feature.

Inmate Login


Login to access features only available to registered Asylum Inmates.
    By default, logging in will set a session cookie that disappears when you close your browser. Clicking on the 'Remember my Moniker & Password' below will cause a permanent 'Login Cookie' to be set.

Moniker/Username:

The Name that you picked or by default, your email.
Forgot Moniker?

 
 

Examples "Rapper", "Bob W", "joe@aol.com".

Password:    

Forgot Password?

 Remember my Moniker & Password ( What's this?)

If you don't have an Asylum Account, you can create one by clicking Here.

Our privacy policy can be reviewed by clicking Here.

Inmate Comments

From:  
Your Email:  
Subject:  

Message Comments

   

Original Message

exactly!

Posted by LtMandella on December 10, 2020 at 18:55:43:

Recently I just heard the exact same symptoms as you described for bad tubes, when listening to my Transcendent Sound OTL tube amp.

Sure enough, I bought a quad of tested and matched EL 509s from the bay (a tube seller with almost 2000, 100% feedbacks) and installed them today.

After settling in and rebiasing a couple times, the amp is sounding great again.

The symptoms you described match perfectly with the issues I was hearing...