Home General Asylum

General audio topics that don't fit into specific categories.

VPI HW-19 bearing issues

I picked up a VPI HW-19 MK2, and the spindle would not turn.

I was able to pull the spindle and shaft. All seems well. There is oil in the bottom of the well, and the spindle slowly sinks into the well when inserted. There is what appears to be a bearing surface on the bottom of the spindle.

However- the spindle will only go down about 80% of the way. It will stop as if hitting a surface, and sit about 1.5 inches above the top of the well. I can push it down further, but it will not turn, and has to be carefully removed.

Spindle shaft appears fine, bottom appears fine. I inserted a narrow shaft into the well, and it goes all the way down. I can not feel any obstruction or protrusions etc, or determine why the bearing shaft will not go all the way down, then spin freely.

Questions:

Any idea what the problem is ?

Should there be a "free floating" bearing, or just the bearing tip in the spindle, against the thrust plate.

I note that some have changed to ceramic bearings. Does this mean removing the bearing end from the spindle ?

Thank you !


This post is made possible by the generous support of people like you and our sponsors:
  Amplified Parts  


Topic - VPI HW-19 bearing issues - Ross 12:17:45 04/24/21 (15)

FAQ

Post a Message!

Forgot Password?
Moniker (Username):
Password (Optional):
  Remember my Moniker & Password  (What's this?)    Eat Me
E-Mail (Optional):
Subject:
Message:   (Posts are subject to Content Rules)
Optional Link URL:
Optional Link Title:
Optional Image URL:
Upload Image:
E-mail Replies:  Automagically notify you when someone responds.